Swt browser No more handles Error

Asked
Active3 hr before
Viewed126 times

6 Answers

browsererror
90%

Stack Overflow Public questions & answers , Meta Stack Overflow , Stack Overflow help chat , Stack Overflow for Teams Where developers & technologists share private knowledge with coworkers

Install libwebkitgtk

sudo apt - get install libwebkitgtk - 1.0 - 0
88%

Exception in thread "main" org.eclipse.swt.SWTError: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]
at org.eclipse.swt.SWT.error(Unknown Source)
at org.eclipse.swt.browser.Mozilla.initMozilla(Unknown Source)
at org.eclipse.swt.browser.Mozilla.create(Unknown Source)
at org.eclipse.swt.browser.Browser.<init>(Unknown Source)
   at org.hekmatof.Hbook.UI.WelcomeTab.init(WelcomeTab.java:55)
   at org.hekmatof.Hbook.UI.WelcomeTab.<init>(WelcomeTab.java:30)
      ...
load more v
72%

Check the SWT FAQ - What do I need to run the SWT Browser inside Eclipse on Linux and SWT Bug 103611 - internet cache didn't work on Linux and especially IBM Support - SWTError: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)].,may not support every behavior on all systems because of native resources used (hint options),heavy components (native/awt) hide swing components, not a problem most of the time as as use of heavy components is rather rare

I wrote a simple program. just a CTabFolder and a WelcomTab inherent from CTabItem. I want to fill my WelcomeTab by a browser which render my htmls. at the init() method of WelcomeTab I Create a Browser but when program want to construct it I get this Error

Exception in thread "main" org.eclipse.swt.SWTError: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]
at org.eclipse.swt.SWT.error(Unknown Source)
at org.eclipse.swt.browser.Mozilla.initMozilla(Unknown Source)
at org.eclipse.swt.browser.Mozilla.create(Unknown Source)
at org.eclipse.swt.browser.Browser.<init>(Unknown Source)
   at org.hekmatof.Hbook.UI.WelcomeTab.init(WelcomeTab.java:55)
   at org.hekmatof.Hbook.UI.WelcomeTab.<init>(WelcomeTab.java:30)
load more v
65%

However, it still doesn't work on the command line with mvn -Dswt.gtk3=0 -Dorg.eclipse.swt.browser.XULRunnerPath=<XULRunner path> verify. I can see it's using GTK2 as expected, but the internal browser is still disabled when I go to Preferences > Web Broswer. I see the familar error message !MESSAGE Internal browser is not available: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)].,The internal browser is disabled in Eclipse on some machines. This interferes with one of our integration tests that runs the dev appserver. It brings up an external browser and steals the focus.,I was able to make our dev appserver integration test to use the internal browser when I run the test inside Eclipse with the above changes.,I'll update the release doc to handle this. This issue depends on environments and requires installing XULRunner at a custom location to work around, so I think it's best to handle in the command line.

!MESSAGE Internal browser is not available: No more handles[Browser style SWT.MOZILLA and Java system property org.eclipse.swt.browser.DefaultType = mozilla are not supported with GTK 3 as XULRunner is not ported
   for GTK 3 yet]
load more v
75%

Hi, I just update MyEclipse to 2017 CI 9 and the log show this error:,Which release of MyEclipse were you using before updating to CI 9 and started to see the problem?,Apologies for the delay as we tried to replicate the issue and figure a workaround. ,Please let us know how you get on and sorry for the continuing problems.

After downloading XulRunner 1.9.2.19 and adding the following option to myeclipse.ini
-Dorg.eclipse.swt.browser.XULRunnerPath=/opt/xulrunner-1.9.2

-Dorg.eclipse.swt.browser.XULRunnerPath = /opt/xulrunner - 1.9 .2
load more v
40%

This is also the error you get if you try to start Eclipse over ssh without forwarding X access. Ie, you forgot to run ssh -X user@host or forgot to include ForwardX11 yes in your ~/.ssh/config entry for the server.,To work around this you'll need to use xauth add to add the initial user you logged in as to root's $HOME/.Xauthority file., Meta Discuss the workings and policies of this site , Business Learn more about hiring developers or posting ads with us

As the user logging into the server which has authority to display to X, run:

xauth extract cookie_file $DISPLAY
load more v

Other "browser-error" queries related to "Swt browser No more handles Error"