How to fix error with xml2-config not found when installing PHP from sources?

Asked
Active3 hr before
Viewed126 times

8 Answers

error
90%

For the latest versions it is needed to install libxml++2.6-dev like that:,"RUN apt-get update && apt-get install -y libxml2-dev",sudo yum install libxml2-devel,"sudo zypper install libxml2-devel"

When I try to install php 5.3 stable from source on Ubuntu (downloading compressed installation file from http://www.php.net/downloads.php) and I run ./configure I get this error:

configure: error: xml2 - config not found.Please check your libxml2 installation.
load more v
88%

Stack Overflow for Teams Where developers & technologists share private knowledge with coworkers ,All you need to do instal install package libxml2-dev for example:,Thanks for contributing an answer to Stack Overflow!, Stack Overflow Public questions & answers

All you need to do instal install package libxml2-dev for example:

sudo apt - get install libxml2 - dev

On CentOS/RHEL:

sudo yum install libxml2 - devel
load more v
72%

When I try to install php 5.3 stable from source on Ubuntu (downloading compressed installation file from http://www.php.net/downloads.php) and I run ./configure I get this error:,I'm having problems with a piece of code that behaves differently depending on whether it was compiled in the Release or Debug configuration in Visual Studio. I...,i am new to scala I have two scala example files under same directory one is: and the other is if u want to refer to the source the link is here : https://githu..., .NET component behaviour difference when changing compilation configuration I'm having problems with a piece of code that behaves differently depending on whether it was compiled in the Release or Debug configuration in Visual Studio. I... zterry · saved on 1 week ago

When I try to install php 5.3 stable from source on Ubuntu (downloading compressed installation file from http://www.php.net/downloads.php) and I run ./configure I get this error:

configure: error: xml2 - config not found.Please check your libxml2 installation.
load more v
65%

All you need to do instal install package libxml2-dev for example:,sudo yum install libxml2-devel,"sudo zypper install libxml2-devel",For the latest versions it is needed to install libxml++2.6-dev like that:

When I try to install php 5.3 stable from source on Ubuntu (downloading compressed installation file from http://www.php.net/downloads.php) and I run ./configure I get this error:

configure: error: xml2 - config not found.Please check your libxml2 installation.
load more v
75%

All you need to do is to install package libxml2-dev via:,See: How to fix error with xml2-config not found when installing PHP from sources?, Installing the dev package doesn't help. I have both libxml2 and libxml2-dev installed band the xml2-config is still missing. – Nicolas Sep 16 '19 at 9:07 ,As you can see, libxml2:amd64 (I have a 64-bit system) is installed.

All you need to do is to install package libxml2-dev via:

sudo apt - get install libxml2 - dev
load more v
40%

configure: error: xml2-config not found. Please check your libxml2 installation.,Home » Linux » PHP configure error: xml2-config not found. Check libxml2 installation on CentOS/RHEL/Fedora,Remove .php extension from the URL [htaccess],For trying out wordpress 3.8 installation, i had to upgrade my php installation from 5.1.6 to 5.2.4 or later version. Unfortunately, through yum, i couldn’t upgrade php! So the other option left was to install from source. Downloaded the latest stable version of php ie, 5.5.7 and started to compile. To my unluck, i ran into following errors:

The quick solution to the above problem is you need to install libxml2-devel package. Easy way of installing it is using yum by issuing the following command on your CentOS/Fedora/RHEL Linux distributions.

[root @catest php - 5.5 .7] # yum install libxml2 - devel
load more v
22%

for i in $PHP_LIBXML_DIR / usr / local / usr;
do
   if test - x "$i/bin/xml2-config";
then
ac_cv_php_xml2_config_path = "$i/bin/xml2-config"
load more v
60%

Under Linux, compiling and installing PHP errors: libxml2 configure: error: xml2-config not found. Please check your libxml2 installation. But libxml2 has been installed under Linux, and I can find it through rpm-qa | grep libxml2. Why do I still prompt for that error?,Have you installed libxml2-devel or something like that?,Libxml2-devel is a development library, which contains header files, static libraries and some related tools for compiling and using libxml2. Installation from source code will include these. Many Linux distributions will be unpacked to separate the parts for development, because many people do not use them.,Bestime on Answer for When I first came into contact with better scroll, I would like to ask the elder why better scroll cannot scroll after initialization?

It should be libxml2-dev
ubuntu/debian:

apt - get install libxml2 - dev
load more v

Other "error-undefined" queries related to "How to fix error with xml2-config not found when installing PHP from sources?"