How to disable "prevent this page from creating additional dialogs"?

Asked
Active3 hr before
Viewed126 times

3 Answers

disable
90%

I'm developing a web app that utilises JavaScript alert() and confirm() dialogue boxes.,Connect and share knowledge within a single location that is structured and easy to search.,You can, however, look into modal popups like jQuery UI Dialog. These are javascript alert boxes that show a custom dialog. They don't use the default alert() function and therefore, bypass the issue you're running into completely.,How can I stop Chrome from showing this checkbox?

This is what I ended up doing, since we have a web app that has multiple users that are not under our control...(@DannyBeckett I know this isn't an exact answer to your question, but the people that are looking at your question might be helped by this.) You can at least detect if they are not seeing the dialogs. There are few things you most likely want to change like the time to display, or what you are actually displaying. Remember this will only notify the user that they are have managed to click that little checkbox.

window.nativeAlert = window.alert;
window.alert = function(message) {
   var timeBefore = new Date();
   var confirmBool = nativeAlert(message);
   var timeAfter = new Date();
   if ((timeAfter - timeBefore) < 350) {
      MySpecialDialog("You have alerts turned off");
   }
}

window.nativeConfirm = window.confirm;
window.confirm = function(message) {
   var timeBefore = new Date();
   var confirmBool = nativeConfirm(message);
   var timeAfter = new Date();
   if ((timeAfter - timeBefore) < 350) {
      MySpecialDialog("You have confirms turned off");
   }
   return confirmBool;
}
load more v
88%

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL), featuresstuff Competitions Conferences News The Insider Newsletter The Daily Build Newsletter Newsletter archive Surveys Product Showcase CodeProject Stuff ,Understand that English isn't everyone's first language so be lenient of bad spelling and grammar., communitylounge Who's Who Most Valuable Professionals The Lounge   Where I Am: Member Photos The Insider News The Weird & The Wonderful

72%

In FireFox Address bar Enter: about:config and press enter.,Accept the warning dialog.,Copy this string to your clipboard: dom.successive_dialog_time_limit,Close the about:config page.

Try this

if (confirm("Do stuff?"))
   Dostuff();
else
   location.reload();

Other "disable-undefined" queries related to "How to disable "prevent this page from creating additional dialogs"?"