CURL error 60: ssl certification issue when attempting to use symfony

Asked
Active3 hr before
Viewed126 times

7 Answers

issueerror
90%

When attempting to use the new command C:> php symfony new blog I receive the error message [GuzzleHttp\Ring\Exception\RingException] cURL error 60: SSL certificate problem: unable to get local issuer certificate.,Make sure you put the path of the certificate in the right one., Stack Overflow Public questions & answers ,Then in your php.ini file insert or edit the following line: curl.cainfo = "[pathtothisfile]\cacert.pem"

you can try the the command line below,it's worked for me

composer create - project symfony / framework - standard - edition my_project_name "2.8.*"
88%

cURL error 60: SSL certificate problem: unable to get local issuer certificate,cURL error 60: SSL certificate problem,Edit: As you mentioned in the comment Below you ran into the issue that you're using the has method multiple times in your code and ran into issues.,https://laracasts.com/discuss/channels/general-discussion/curl-error-60-ssl-certificate-problem-unable-to-get-local-issuer-certificate

First of all I'm using wamp server which has PHP version 5.6 and 7 I saved the cacert.pem from the link https://curl.haxx.se/ca/cacert.pem and placed it to C:wampbinphpphp7.0.4ext and to C:wampbinphpphp5.6.19ext and edited php.ini file of respective version and added the following at end of the file:

[cURL]
curl.cainfo = "C:wampbinphpphp7.0.4extcacert.pem"

and

[cURL]
curl.cainfo = "C:wampbinphpphp5.6.19extcacert.pem"

Well this didn't worked so I searched more I came to know that I need to install guzzlehttp/guzzle So I did so, while using the version ^6.0 I was still getting the same then I tried version ^4.0 as it was suggested in many blogs, while doing so I was getting a bindshared error:

  SymfonyComponentDebugExceptionFatalErrorException]
  Call to undefined method IlluminateFoundationApplication::bindShared()

  ?[37;41mScript php artisan optimize handling the post-update-cmd event returned with an error?[39;49m


  ?[37;41m ?[39;49m
  ?[37;41m [RuntimeException] ?[39;49m
  ?[37;41m Error Output: ?[39;49m
  ?[37;41m ?[39;49m

  ?[32mupdate [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--with-dependencies][-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [?[39m?[32m<packages>?[39m?[32m]...?[39m
load more v
72%

I am trying to validate Google Id Token in my Guard Authenticator ( Symfony 4.4). I get the id token from a get request. When i try to validate the token using code below i get this error: cURL error 60: SSL certificate problem: unable to get local issuer certificate (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) It is wired because it has worked before., Pull requests , Pull requests 5 ,This error indicates a misconfiguration on the machine running your application. Take a look at the various solutions discussed here and let me know if that helps.

  $client = new\ Google_Client(['client_id' => null]);
  $payload = $client - > verifyIdToken($credentials['id_token']);
65%

cURL error 60: SSL certificate problem: unable to get local issuer certificate.,If the installer doesn't work for you or doesn't output anything, make sure that the PHP Phar extension is installed and enabled on your computer.,If the SSL certificates are not properly installed in your system, you may get this error:,Download a file with the updated list of certificates from https://curl.haxx.se/ca/cacert.pem

1
2
3
$ sudo mkdir - p / usr / local / bin
$ sudo curl - LsS https: //symfony.com/installer -o /usr/local/bin/symfony
   $ sudo chmod a + x / usr / local / bin / symfony
load more v
75%

I can see there's one serious code related error, another one suggests there's a problem with a certificate you use on your server to collect stats (by the way how does one opt-out from that?),Seeing as you are having trouble getting SSL certs for both the updates server:,[2021-08-31 06:18:43] mautic.ERROR: UPDATE CHECK: Could not fetch a release list: cURL error 60: SSL certificate problem: unable to get local issuer certificate (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://api.github.com/repos/mautic/mautic/releases [] [],So the certificate thing is addressed but you still have the error with GrapesJS? It's helpful to try and separate out issues so that we can make sure there is clarity on what is being addressed.

0
40%

This error occur when the curl.cainfo and openssl.cafile config properties of the php.ini file, do not target any valid certificate that allow you to create connection with ssl as they will be invalid. You'll face it if you work with cURL or you use any kind of tool that creates request to external servers.,Finally restart apache and any other services like mysql and try doing again whatever you were doing. The request now should be working without any problem.,Even in some xampp distributions, in your php.ini you will not find the curl or openssl area, therefore just add it at the end of the php.ini file and save changes.,If you locate your php.ini file, and you search for [curl], these parameters will probably be commented and without any value :

If you locate your php.ini file, and you search for [curl], these parameters will probably be commented and without any value :

[curl];
A
default value
for the CURLOPT_CAINFO option.This is required to be an;
absolute path.;
curl.cainfo =

   [openssl];
The location of a Certificate Authority(CA) file on the local filesystem;
to use when verifying the identity of SSL / TLS peers.Most users should;
not specify a value
for this directive as PHP will attempt to use the
;
OS - managed cert stores in its absence.If specified, this value may still;
be overridden on a per - stream basis via the "cafile"
SSL stream context
;
option.;
openssl.cafile =
load more v
22%

Do not ever modify files in the vendor / folder.Ever.They can and will be
overwritten on the next composer update you run.

Here is my Solution
for WampServer

I am using PHP 7.1 .9
for my WampServer, so change 7.1 .9 in the example below
to the version number you are currently using.

1. Download this file: http: //curl.haxx.se/ca/cacert.pem
   2. Place this file in the C: \wamp64\ bin\ php\ php7 .1 .9 folder
3. Open php.iniand find this line: ;
curl.cainfo

4. Change it to:
   curl.cainfo = "C:\wamp64\bin\php\php7.1.9\cacert.pem"

5. Make sure you remove the semicolon at the beginning of the line.

6. Save changes to php.ini, restart WampServer, and you 're good to go!

Other "issue-error" queries related to "CURL error 60: ssl certification issue when attempting to use symfony"