Can't type a "}" in PhpStorm

Asked
Active3 hr before
Viewed126 times

4 Answers

90%

Possible duplicate of Weird keyboard locks in IntelliJ IDEA (delete & arrow keys, etc.) – Jithin Pavithran Jun 27 '17 at 9:54 ,I'm using IntelliJ IDEA on my Mac to work on a project, and I keep on coming across an issue where I can't type. Occasionally when I switch to another application and then switch back to IntelliJ I can't type anything, and the cursor doesn't appear on text when I click on things. Does anyone know what causes this? After 1-2 minutes it goes back to normal, but it's started happening more frequently and it's pretty frustrating to not be able to type and have no way to fix it.,I had a problem with entering characters when working with .story files. When I tried to type in any character, it appeared for a short while and immediately disappeared. The cause of the problem was jbehave plugin I was using. After uninstalling it and restarting IntelliJ everything was fine.,vi is a powerful text editor since ever. But only if you pretend and know how to use it... There is even a warning on the IDEA install saying like "do not install unless you are familiar with Vim" in yellow bold text, iirc.

load more v
88%

It's exactly your issue, and it has a potential workaround:,You should look at this bug here: http://youtrack.jetbrains.com/issue/IDEA-79312,Option 3: The most universal workaround is still ibus restart, but I think it is worth to quote the assignee of the issue:,Option 2: Official workaround, is to add following line to your ~/.profile

It's exactly your issue, and it has a potential workaround:

sudo ibus restart
load more v
72%

1. Navigate to ‘File’, then ‘Settings’, then ‘Plugins’ and type IdeaVim in the plugin search box. Mark the checkbox to the right of the plugin name and click “Apply”. 2. Restart PhpStorm. 3. Turn on the plugin via checking ‘Tools’ then ‘Vim Emulator’,Almost all Vim shortcuts are supported by the plugin.,Using shortcuts can drastically increase your productivity, but if it’s not enough for you, the next level is the IdeaVim plugin.,Navigate to ‘Settings’, then ‘Editor’, then ‘Live Templates’, choose ‘PHP’, and click on the green ‘+’ at the right-top of the popup window:

load more v
65%

worked for me. You don't have to run ibus restart every so often.,After asking PhpStorm Support, I was suggested to use other type of JDK. He said because of a known bug for OpenJDK that should be fixed in the next minor IDEA release,Then the problem didn't occur again, after I have tested using a day without problem, so I write this answer.,From my point of view, PHPStorm has some problem with OpenJDK with different behavior. Mine is as I stated in my question. In addition, this problem happen not only after Find Occurence or using keyboard shortcut, but happen when I did nothing, it just happen pretty often.

Try this

sudo ibus restart
load more v

Other "undefined-undefined" queries related to "Can't type a "}" in PhpStorm"